升級版本

CentOS yum 只有php5.1.6

但工作需要因此在網路上找方法讓php 5.2.1 升級到5.3.8

參考

http://www.webtatic.com/packages/php53/

http://blog.smps.tp.edu.tw/~kcodavid/index.php?load=read&id=564

首先

1.rpm -ivh http://repo.webtatic.com/yum/centos/5/`uname  -i`/webtatic-release-5-0.noarch.rpm

2.

安裝 

yum --enablerepo=webtatic install php

升級

yum --enablerepo=webtatic update php

但php5.3.8  有許多安全性的修改使得先前的函式會產生安全性警告

因此,可以升級到5.2.17

yum --disablerepo=* --enablerepo=webtatic --exclude=php*5.3* update php

 

降級版本

若已經安裝到5.3.8造成網站產生許多警告訊息,可以利用降級的方法恢復

1. 先移除php 包含php套件等

yum remove php*

2.

yum --disablerepo=* --enablerepo=webtatic --exclude=php*5.3* install php  (將會安裝5.2.17)

3.安裝 php套件

yum --disablerepo=* --enablerepo=webtatic --exclude=php*5.3* install php-mbstring

如安裝 php-mcrypt , php-devel , php-gd , php-mysql 等

可參考

http://www.webtatic.com/packages/php53/

創作者介紹

學無止盡.....

npulove 發表在 痞客邦 PIXNET 留言(0) 人氣()